Jump to content



Photo

FICM & TCM reflash problems


  • Please log in to reply
6 replies to this topic

#1 Trashdawg

 
Trashdawg

    Member

  • Members
  • 26 posts
 

Posted 17 March 2007 - 02:25 PM

I installed the a new FICM today and the program loaded fine onto the FICM then it goes to TCM and goes about 10% and stop and gives me Error Codes 102-0x22 851082, and error code 215-0x0 851082 , testman error 12 56 112021. The TCM is no responding. Both the PCM and FICM have the lastes update, the new FICM fixed the other problem I have having with a failing high and low on #2,3,5. I ran a buzz test and it all passed. I then tryied to retry the FICM flash so it would maybe fix the TCM. That did not happen, I now get U0101 Lost of Comm with TCM, U0105 Lost of Comm with FICM, U0306 Software incompatible with FICM. Any suggestions?

Thanks

#2 Jim Warman

 
Jim Warman

    Advanced Member

  • Inner Circle Member
  • 2,750 posts
  • Gender:Male
  • Location:Slave Lake, Alberta, Canada
  • Interests:All types of motor racing, camping, hunting, fishing, my family and career.... and my Harley
 

Posted 17 March 2007 - 11:25 PM

Are you using PDS or IDS.... what is your software level? Any help from hotline?

Jim Warman
Ford Master Tech - Diesel Certified
Stercus Accidit


#3 Trashdawg

 
Trashdawg

    Member

  • Members
  • 26 posts
 

Posted 18 March 2007 - 01:19 PM

I am using PDS w/VCM version 48, I am a independent shop.

#4 Jim Warman

 
Jim Warman

    Advanced Member

  • Inner Circle Member
  • 2,750 posts
  • Gender:Male
  • Location:Slave Lake, Alberta, Canada
  • Interests:All types of motor racing, camping, hunting, fishing, my family and career.... and my Harley
 

Posted 18 March 2007 - 04:45 PM

The comm codes have me scratching my head.... The pinpoint test for U0101 is pretty straight-forward but I've been bitten before... I'd check the fuses and load test the powers and grounds with a headlamp. The other codes may be a symptom of U0101

I'd probably try programming using PMI (programmable module installation) and as built data at some point before I condemned the PCM. As built data should be available at motorcraft.com.

Jim Warman
Ford Master Tech - Diesel Certified
Stercus Accidit


#5 Trashdawg

 
Trashdawg

    Member

  • Members
  • 26 posts
 

Posted 19 March 2007 - 10:07 AM

Today I did the PMI, PCM and FICM are on the same page but keep getting error 215 0x0 851082. Truck passes buzz test and only KOEO code I get now is U0101 lost comm with TCM. I tried the reflash on TCM about 10 times and it only went to 15% at the most. I guess I am looking at a new PCM.

#6 Warren Johnson

 
Warren Johnson

    ADMINISTRATOR

  • Staff
  • 6,144 posts
  • Gender:Male
  • Location:Minnesota
 

Posted 19 March 2007 - 10:15 AM

This may not be a problem but I have had some crazy (censored) happen.... Did you remove the FICM relay when you programed. I have been succesfull with and without removing the relay but I have also had problem when I have not removed it.

From the sound of your post the TCM was fine untill the FICM was replaced. and then you get a communication error with the TCM. Try and plug the old FCIM back in and program to sere if it will compleat the programming befor you replace a PCM
Warren Johnson, Administrator
Senior Master Technician
ASE Master Technician

#7 Trashdawg

 
Trashdawg

    Member

  • Members
  • 26 posts
 

Posted 23 March 2007 - 04:45 PM

Update: Tried going back with old FICM but TCM would not come back online. I was removing the FICM fuel when flashing, Replaced PCM and everything works great. This truck had the ALT go bad and ran it til the battery's went dead. I don't know if it had anything to do with it.
Thanks




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users