Jump to content



Photo

'95 Infiniti J30 Fuel Issue


  • Please log in to reply
2 replies to this topic

#1 indiglo82

 
indiglo82

    Newbie

  • Members
  • 1 posts
  • Location:Palm Beach County, FL, USA
 

Posted 09 February 2008 - 01:27 AM

Hi all :) I'm hoping someone here could help me. I just purchased a 1995 Infiniti J30 from a private seller a couple days ago. The car has been great, until today. First, I'll give a bit of background information. I'm an entry-level mechanic at a Mazda dealership, have completed a year of technical school and have hands-on experience from working on family vehicles. With this in mind, I know how difficult it is to diagnose a vehicle over the phone or internet, so I'll try my best to describe the exact conditions to you. The first time I filled this car up with fuel, I made a mistake. I accidentally filled the car up with regular octane gasoline instead of premium as the car requires -- I'm sure this is due to me being so used to putting regular in with my old car that I just went into the routine and didn't notice until it was too late. I know with OBD-II vehicles the timing will retard to compensate for lower octane fuel, though this car is OBD-I. I started the car and it ran fine for about a day. Today it's giving me problems. After driving the car around all day today, I went to a restaurant and when I came out and started the car, I immediately got a CEL and the car stalled. I was able to start the car up again, CEL was still on and when I drove it around the parking lot it wouldn't go above 10-15 mph and 2,500 RPM. I'm assuming this is limp-home mode, but I can't be sure since this is the first time I've experienced it. The engine will run smoothly at idle but will run a little rough if you rev it a bit. Upon opening the gas cap, a rush of air comes out (audibly, too) that smells VERY strongly of gasoline. The exhaust also smells very strongly of unburnt fuel and gives off some white smoke at times. I checked the oil for signs of coolant (milky/coffee-colored fluid) and didn't find any. The seller changed the oil right before I bought the car, but I've driven it for 25 miles or so since I purchased it and would think coolant would be present by this time if it were a blown head gasket. With the car cool, I took off the radiator cap and noticed the coolant looked normal -- not milky or anything. I'm pretty sure if it were a blown head gasket, the exhaust would also smell like coolant -- which it didn't. My theory here is that the rest of the premium fuel in there burned off and the regular fuel entered the fuel system. When the regular fuel entered the combustion chamber, a combination of the low octane and (likely) lots of carbon build-up causing higher compression, it pre-detonated, and the ECU noticed and put the vehicle into limp-home mode. I *was not* able to read the codes due to not having any tools with me (to remove the ECU from it's mount on the passenger side kick panel) and it also being nearly midnight at the time. I plan on checking the codes tomorrow when there's daylight. I'm wondering if all I'd need to do would be to toss in a can of octane booster and run the tank empty and re-fill with premium -- but with my luck, I doubt that's the case :( Basically, the car won't go above 15 mph/2,500 RPM, has a CEL on, "whoosh" of air that smells strongly of fuel when the gas cap is loosened (something in the back of my mind says purge valve, but I doubt this), raw fuel smell in the exhaust (which I'm thinking is because the fuel isn't burning properly in the combustion chamber and going straight into the exhaust?) and, basically, everything else seems fine. Before this, the car performed flawlessly -- everything worked and the car drove perfectly. I really hope I didn't just get scammed out of $3,000 :( Any ideas? Edit: Did some work on the car today. I added octane booster to raise the octane of the regular grade fuel that's in there. Car seemed to run better. I pulled the codes from the ECU, and it gave me a code 34 (knock sensor, I'll bet from the lower grade fuel) and code 12 (mass air flow sensor). I cleared the codes, started the car, CEL came back on. This time it was only giving a code 12, code 34 didn't come back presumably because of the higher octane fuel in there now. I can get the car up to speed now, but it won't let me go above 2,500 RPM. It also tries to/actually does stall when I put the A/C on, but will run fine if you prevent it from stalling. Also, I tried cleaning the MAF with brakleen to no avail. My question now, is whether or not the MAF could cause the engine not to go above 2,500 RPM; and whether or not there's anything else I should check (grounds, opens, wiring in general, etc.) -- I back-probed the connector at terminal B and put the other voltmeter lead to ground -- got 0.012v, way below the 0.8v minimum spec. Before I go out and buy a MAF, is there something I'm forgetting? Does this sound like a typical failed MAF problem? Anything else to check?

#2 Karrpilot

 
Karrpilot

    STAFF

  • Staff
  • 6,176 posts
  • Gender:Male
  • Location:Chicago Zone
  • Interests:Ex Ford Tech 22 years.
 

Posted 12 February 2008 - 08:43 PM

Did the car back fire from the wrong fuel ? It is a long shot, but that could have taken out the MAF sensor. I have seen intake manifolds (plastic ones) get blown apart from a good back fire.

No longer working at dealerships. Government employee. Now i get paid to fix Fords.
ASE master tech
Private Pilot High Performance / Complex Rating.


#3 Aurora

 
Aurora

    Volvo Moderator

  • Members
  • 212 posts
 

Posted 26 February 2008 - 10:39 PM

you should put a scanner on it and look at he MAF readings, sounds like a bad load signal, did you make sure the air bellow from the air flow meter to the throttle housing is intact? the knock code may be due to the faulty mas air flow but I have seen infinity's with defective knock sensor harnesses, low octane fuel isnt going to cause your rpm problem. second using any kind of chemical on the mass air flow is a mistake in its self
6 year Volvo Master Tech
Volvo Semi Finalist Vista Program

I buy old Aurora Slot Cars from the 60's and early 70's
(hence the name Aurora) if ya got-um I buy-um


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users